﻿ 关于我们

王码的历史和发展

“五笔字型”汉字输入技术的第一代版本，是王永民教授于1978年至1983年在南阳完成河南省重大科研项目时获得的一项科研成果。这是一项集多学科知识的一个创造。依据王永民教授提出的“形码设计三原理”和“汉字字根周期表”，王永民教授发明的4码形码汉字编码法和字词兼容技术，于1983年在世界上首破汉字输入电脑每分钟100字大关。该项开创性发明，因突破中文电脑化的“瓶颈”，被国内外专家誉为中国文化史上“不亚于活字印刷术”的重大发明，并由此创造了实用化的“中国信息时代全新的汉字书写方式”。五笔字型是中国唯一获得中、美、英三国专利，并向IBM、DEC、CASIO、Microsoft、WYSE等20余家世界级著名电脑公司出口、经国家科委和国防科工委正式发文向全国、全军推广应用的汉字输入技术。

“五笔字型”是一种完全依照汉字的字形、不计读音，不受方言和地域限制，只用标准英文键盘的25个字母键，便能够以“字词兼容”的方式，高效率地向电脑输入汉字的编码法及其软件。这一技术，编码规则简单明了，重码少，5区25个键位设计规律性强，键位负荷与手指功能匹配协调（打起来顺手），因而好学易用、效率高，不但在中国装机最多、应用最广、一直处于主导地位，而且10多年来在联合国总部、东南亚各国，其应用也越来越广。

因为“五笔字型”是姓“王”的王永民所发明的一种“汉字编码”，所以世人也将“五笔字型”简称之为“王码”。至于后来鉴于“王码”用户最多，应用最广，人们认为“王码”有“码中之王”、“王牌编码”的意思，这只能是从实践中产生的一种概念引申，就算是姓“王”的天生要占的一个“便宜”吧！

“王码”既是一部历史，又是一项不断扩大内涵的技术。从1983年五笔字型问世后，作者先后共推出了三个定型版本。1986年推出的86版（4.5版），也即当前国内外应用最广的版本，是“五笔字型”的第一个定型版本；1998年推出了符合规范的98版；之后又推出了可纳入中小学教育的大一统版。

多年来的推广，五笔字型早已成为在国内用户占有率超过90％的汉字输入技术，在全世界的华文报业、联合国总部也都采用五笔字型输入汉字。


D4-5-1

五笔字型版本过渡

五笔字型自发行以来，有三类版：

① 86版，延伸版本：4.0版、4.5版和18030版；

② 98版，包括9801版、9803版、9804版及9808版。

③ 新世纪版，该版本也被称为标准版。

86及98两类版本各俱特色，但经过二十几年的实践考验，五笔字型老版本仍有需要完善及改进之处，由此，王永民教授数十年如一日，潜心研究，终又发明了五笔字型的终极版本：新世纪版。新版本取86及98版之优点，去其繁冗之节，众望所归，新世纪版被定为五笔字型的大同版本。

为使五笔字型老用户顺利过渡到新世纪版，以下将着重讲述86版及98版与新世纪版的区别。


D4-5-2

86版到新世纪版的过渡

1983年发行的86版五笔字型，正是由于其无与伦比的技术优势，所以即使当前，依然拥有广大的用户群。与时俱进，新世纪版在此基础上做了如下改进：

1、规范性

86版在某些字中的末笔识别码的取法上迁就了习惯写法，如：

我、找、龙、成……

这些字由于有一大部分有倒插笔的习惯，所以在86版中，人为地规定末笔为“丿”。而在国家笔顺规范中，这些字的末笔为“丶”，因此，在新世纪版编码时，统一将这些字规定为依照国家标准，末笔均定义为“丶”。

2、字根精减

为确保编码方案最优，为更加方便用户记忆字根，新世纪版字根有所减少，比86版少许多字根。

3、键位变动

以理论与实践为基础，为确保编码方案最优，对86版的7个字根的键位做了变动，放置在新世纪版的字根图中。

如：字根“乃”，在86版中是在“E”键上，但由于其规范笔顺为“乙、丿”，所以，新世纪中将该字根安排在了“乙”区的“B”键上。

4、编码兼容

新世纪版有着科学、完备的的编码体系，与86版、98版均有不同之处，但用户不用担心，新世纪版对这两个版本均做了兼容处理。


D4-5-3

98版到新世纪版的过渡

1998年通过鉴定并推出的98版五笔字型，在编码的规范性上做了一定的改进，符合了国家标准，但在适应性、字根易记性等方面，仍有欠余，新世纪版对此做了如下改进：

1、规范性

98版在编码取码上进行了规范性的改进，象“我、找”等字，用户书写习惯有的是以“丿”为末笔，有的是以“丶”为末笔，在98版中，都按照国家笔顺规范，定义这些字的末笔为“丶”，在新世纪版编码体系中，同样也沿袭了这些标准，末笔均定义为“丶”。

2、字根精减

为规范字根考虑，98版的字根偏多，用户在学习时就要增加记忆因素，为降低学习难度，使用户更快捷地记忆字根，新世纪版版比98版的字根减少很多。

如：98版U键上有“立、六、辛”等14个字根，在新世纪版中将这14个字根精减到了10个，有效地减少了记忆因素。

3、键位变动

以理论与实践为基础，为确保编码方案最优，对98版的4个字根的键位做了变动，重新放置在新世纪版的字根图中。

如：字根“牜”，在98版中是在“C”键上，考虑该字根以“丿”起笔，所以，新世纪中将该字根放在了“丿”区的“R”键上。

4、编码兼容

新世纪版有着科学、完备的的编码体系，与86版、98版均有不同之处，但用户不用担心，新世纪版对这两个版本均做了兼容处理。


2-1-1.htm

五笔字型输入法的特点

"五笔字型"是一种高效率的汉字输入法，是只使用25个字母键，在键盘上汉字的笔画、字根为单位，向电脑输入汉字的方法。这一输入法，是在世界上占主导地位、应用最广的汉字键盘输入法。其主要特点如下：

（1）世界上重码最少的汉字输入法

纯形编码，编码的唯一性好。适合专职和非专职人员共同使用。按照"形码设计三原理"设计的字根键位分布，实现了同一键位上若干字根的相容性，合理地分配了编码空间，使重码减少到最低限度。平均每输入10000个汉字，仅有1～2个字需要人工挑选。

（2）不受读音方言限制

GB18030-2000字集的汉字有27533个，中等文化水平的人只认识其中的3000个字左右，将近90％不认识或受方言影响读不准的字，只能用"形码"输入。

（3）有效地克服同音字、同音词

数万个汉字只有400多个读音，在GB18030中，读LI、JI、BI、XI、YI音的字都多达数百个；由同音字构成的同音词如"事实、失事、逝世、誓师……"，用"音码"无法辨别。然而用五笔字型输入时，字形不同，编码不同，特别适合汉字的特点及广大有方言的地区。

（4）输入效率高

五笔字型用双手十指打键。经过标准的指法训练，每分钟向电脑中输入100个汉字很是平常。1998年"京城五笔字型大奖赛"，冠军的速度是（在错1罚5的严厉评判规则下，输入生稿连续测试10分钟）经国家公证处公证，每分钟输入生稿293个汉字，创造了汉字输入的世界纪录。

（5）字词兼容

用五笔字型既能输入单字，还能输入词汇。无论多么复杂的汉字最多只打4下键，不超过32个汉字的词汇也只打4下键。字与词之间，不要任何转换或附加操作，既符合汉字构词灵活、语句中字和词难以"切分"的特点，又能大幅度地提高输入速度。

（6）越打越顺手

"五笔字型"依照"形码设计三原理"研究完成，实现了科学的"多目标"的统一。字根在键位上的组合符合"相容性"――使重码最少；键位安排符合"规律性"――使字根易记易学，而指法设计的"谐调性"――则使得各个手指的击键负担趋于合理，打起来顺手，越打越快。

（7）全球通用

"五笔字型"经过长久的大规模社会实践的检验，已成为在国内外占主导地位的汉字输入技术，具有很好的通用性。学会了"五笔字型"，到处都有现成的电脑可供使用；厂家的电脑类产品装入了"五笔字型"，全国乃至世界各地，都有成百上千的人不经训练便会操作。


2-1-2.htm

汉字的5种笔画

字根由笔画写成。笔画、字根、整字，是汉字结构的三个层次。

笔画是：书写汉字时，一次写成的一个连续不断的线段。

汉字的五种基本笔画是：横（一）、竖（丨）、撇（丿）、捺（ [image] ）、折（乙），分别用１、２、３、４、５代表。其中:

    ●提笔“ [image] ”实际是横“一”的变形。

    ●点笔“丶”是捺“ [image] ”的变形。

    ●竖左钩“亅”是竖“丨”的变形。


2-1-3.htm

汉字的3种字型

习惯上，我们把构成汉字的基本笔画结构，称作“字根”或“部件”。根据构成汉字的各个字根之间的“位置关系”，我们可以把成千上万个方块汉字，分为以下3种字型：

左右型（字根左右排列）；上下型（字根上下排列）；杂合型（字根互相包围或交叉套迭）。

现在，我们根据3种字型拥有字数的多少，顺序将3种字型命以数字代号1、2、3。

从此以后，我们便约定：

●1型字，即指“左右型”汉字，其代号为1；

●2型字，即指“上下型”汉字，其代号为2；

●3型字，即指“杂合型”汉字，其代号为3；

将来，在给汉字编码时，“字型”及其代号将是非常有用的编码信息。但是，仅仅对于那些由2个或3个字根组成的字，我们才关心它的“字型”。如果一个汉字由4个或4个以上的字根组成，仅仅字根的编码已经达到了最大长度4个码，编码时，我们就不再计较是什么“型”，即不再追加“识别码”了。


2-2-1.htm

五笔字型键盘的各区字根

第1区－横起笔

第1区：5个键上的字根及其助记词如下：


2-2-2.htm

第2区－竖起笔

第2区：5个键上的字根及其助记词如下：


2-2-3.htm

第3区－撇起笔

第3区：5个键上的字根及其助记词如下：


2-2-4.htm

第4区－点起笔

第4区：5个键上的字根及其助记词如下

注：1. 助记词中，45.P键上的“礻”读“示”，45.P键上的“衤”读“衣”。


2-2-5.htm

第5区－折起笔

第5区：5个键上的字根及其助记词如下：


2-1-5.htm

五笔字型键盘的区位号规律

现以2区5位的M键为例，介绍快速记住字根区位码的方法。

第2区第5位M键如下：

由这个键可见，记住字根所在的键，可以遵循以下3点“规律”:

（1）区号与首笔代号一致

（2）字根的位号与字根的第二笔代号一致

至此，大部分字根，只要用笔画代码“读”它的前2个笔画，就构成了字根的“区位号”（请记住，字根的这个“区位号”，正好是字根的五笔字型编码！）。

（3）单笔画的“个数”与其所在键的“位号”一致

一、 丨、 丿、 、 乙， 这5个单笔画，都在第1位；
二、 、 、 、 ， 这5个双笔画，都在第2位；
三、 、 彡、 氵、 ， 由3个单笔构成，都在第3位;
、 灬， 由4个单笔构成，都在第4位。

依照以上3项规律，可立即知道以下几个字的“字根”在哪个键上：

例1. 参

厶：（首笔为折--5，次笔为点--4）在5区4位，　54（C）

大：（首笔为横--1，次笔为撇--3）在1区3位，　13（D）

彡：（撇在3区--3，系3个撇--3）在3区3位，　　33（E）

而54、13、33或CDE，就是“参”的五笔字型编码，即输入码。


2-1-4.htm

5区25位的五笔字型键盘

汉字是由字根构成的，如“李”字是由“木”和“子”组成。输入“李”字时，就要依照书写顺序敲击“木”和“子”所在的键，这就好像是在电脑里让“木”和“子”拼合成了一个“李”字。

王永民教授将构成汉字的字根，优选归纳为130种，按字根的首笔或次笔的笔画代号，有规律地分配在25个英文字母键上，形成了五笔字型的“字根键盘”。

五笔字型键盘分为5个区，区号从1到5；每一个区，各有5个键位，位号也是从1到5，位号从键盘中部向左右两端排列；区号与位号组合，共形成5×5=25个代码11，12……54，55。每个“区位号”与一个英文字母对应，其对应关系是：


861-5-1

86版五笔字型简体字根键位图


861-5-2

86版五笔字型简繁体字根键位图

注：45.P键上的繁体字根“ [image] ”仅用于繁体偏旁“ [image] ”中，“ [image] ”的编码为：人 [image] （34 45，WP）。


862-1

86版五笔字型编码流程图


2-3-1.htm

码元汉字输入法

键名汉字输入

每个键位上左上角的字根，及每句助记歌的第一个字，叫键名、键名字或键名字根。

键名字的输入法是：把所在的键连打4下。例如：

1区1位键名： 11 11 11 11 （GGGG） → 王
3区2位键名： 32 32 32 32 （RRRR） → 白

在标准五笔字型输入法中，键名字根有25个

1区：王土大木工 2区：目日口田山

3区：禾白月人金 4区：言立水火之

5区：已子女又纟


2-3-2.htm

成字码元输入

除键名以外，凡本身是汉字的字根，叫“成字根”或“成字字根”。其输入法分为两步：

① 先打一下它所在的键（这一下俗称“报户口”）；

② 再打该字根的第一个、第二个及最末一个单笔画，共4下；不足4键时，补一个空格键。

例如：

    用:　用　　丿　　乙　　丨　　　　米:　米　　丶　　丿　　丶

         33　　31　　51　　21　　　　　　 44　　41　　31　　41

         E　　 T　　 N　　 H　　　　　　　O　　 Y　　 T　　 Y

成字字根（包括平时不作为汉字、但也有国标码的偏旁、部首），计有100多个。其中本身是常用汉字的如：

1区：戋五一干士十二寸雨犬三古石厂丁西七（17个）

2区：上止早虫川甲四车力由贝几（12个）

3区：竹斤手乃八夕儿（7个）

4区：文方广辛六门小米（8个）

5区：心尸羽耳了也刀九巴马弓匕（12个）


2-3-3.htm

补码码元及其输入

五种笔画 “一丨丿丶乙”的输入方法是：先打两下该笔画所在的键，再加打两下“L”键。

具体编码如下：

一：G　　G　　L　　L　　(11　　11　　24　　24 )

丨：H　　H　　L　　L　　(21　　21　　24　　24 )

丿：T　　T　　L　　L　　(31　　31　　24　　24 )

丶：Y　　Y　　L　　L　　(41　　41　　24　　24 )

乙：N　　N　　L　　L　　(51　　51　　24　　24 )

说明：“一”作为常用字，被选作“高频字”，还可以打它的简码，只要打一个“G（11）”，再打一个空格便可输入。

注：其所以作如上规定，是为了把简短的编码“让位”给更常用的字，即“合理分布编码空间”。


2-4-1.htm

合体字的输入

凡是“字根总表”上没有的汉字，也即“键外字”，都可以认为是由字根和笔画拼合而成的，这类字我们称之为“合体字”。


2-4-2-1.htm

合体字的取码规则

（1）规范笔顺

“合体字”的编码，一般情况下，要按照正确的书写顺序进行。

例如：新：　立　　木　　斤　　（笔顺正确）

            立　　斤　　木　　（笔顺错误）


2-4-2-2.htm

取大优先

要以“再增添一个笔画，便不能构成笔画更多的字根”为限度，拆取“笔画尽可能多”的结构作为字根，这叫做“取大优先”。

例如：建： 　二　丨　廴　（正确）

             一　十　廴　（错误，因“十”的横笔可以向前凑，使“一”成为笔画更多的“二”）

注：“取大优先”，俗称“尽量往前凑”，是在拆分汉字时，最常用到、使拆分具有唯一性的基本规则。离开这一规则，必然使一个字有许多种拆法，使编码缺乏唯一性。例如，夷，按规范笔顺和取大优先只能拆成“一弓人”，因“弓”的第一笔添不到“一”上，“人”的第一笔也添不到“弓”上，所以拆成“一弓人”已经是“尽可能往前凑”了。另外，“夷”如拆成“大弓”，显然又违背了规范笔顺，固不可取。


2-4-2-3.htm

兼顾直观

在编码时，为了使字根特征明显易辨，有时就要暂时牺牲“书写顺序”和“取大优先”的原则，形成极个别例外的情况。

例：“国”字，按“书写顺序”，其字根应是：“冂王丶一”，但这样编码，不但有悖于该字的字源，也不能使字根“囗”直观易辨。我们只好违背“书写顺序”，按“囗王丶”的顺序编码。

同样的例子又如：

    自:丿　目　　（正确，似乎没有“取大优先”，但直观性很好。）

        亻　　三（错误，虽“取大优先”，但缺乏直观，且又太散。）


2-4-2-4.htm

能连不交

例如：天： 一　大（正确，“一”与“大”视作相连接，比较直观。）

           二　人（错误，“二”与“人”交叉在一起了。）

一般来说，“连”比“交”更为“直观”，更能显现字根的笔画结构特征，更易于辨认。所以，当有几种取码可能性时，“连”的应比“交”的优先。


2-4-2-5.htm

能散不连

有时候，一个汉字的几个字根，都不是单笔画，这些字根之间的关系，常常在“散”和“连”之间模棱两可。如:

    占： 　口

两个字根按“连”处理，便是杂合型（3型）字，如按“散”处理，便是上下型（2型）字。如:

    矢： 　大

当遇到这种既能“散”，又能“连”的情况时，我们规定：只要不是单笔画，一律按“能散不连”判别，即优先确定为“散”的关系，叫做“能散不连”。


2-4-3-1.htm

“多元字”的取码规则

所谓“多根字”，是指有4个以上字根的字。这种字，我们仅仅“按书写顺序取第一、二、三及最末一个字根编码”，俗称“一二三末”，共编4个码（不再加“识别码”）。

例如:　　戆：立　　早　　夂　　工　　贝　　心

             42　　22　　31　　　　　　　　51

             U　　 J　　　T　　　　　　　　N


2-4-4-1.htm

“四元字”的编码规则

“四根字”是指刚好由四个字根构成的字。其取码方法是“依照书写顺序将四个字根编码”。

例如:照：　日　　刀　　口　　灬

           22　　53　　23　　44

           J　　 V　　 K　　 O


2-5-5-1.htm

二根字和三根字的取码规则及“识别码”

（1）末笔字型识别码

在使用25个键输入汉字的情况下，使用“识别码”可以极为有效地克服重码。

● 必要性之一：因字根相同，"字型"不同引起了重码:

    吧：　口　　巴　（23　54，KC）　　邑：　口　　巴　（23　54，KC）

这个例子说明，编码中丢失了“字型”信息，才使编码完全相同。可见，为避免重码，字型信息不能丢！

● 必要性之二：因几个字根被放在同一键位上引起了重码:

    沐：　氵　　木　（43　14，IS）　　汀：　氵　　丁　（43　14，IS)

    洒：　氵　　西　（43　14，IS）

这个例子说明，因为“木、丁、西”同处一个键，才使三个字的编码完全相同。

由此可知，为了避免几个字的编码相同（重码），既不能丢掉“字型”信息，又有必要提取同键位字根的“笔画特征”用于编码。将这两类有区分重码能力的信息复合起来，就是“末笔字型识别码”，简称“识别码”。

“识别码”是由“末笔”代号加“字型”代号构成的一个“复合附加码”。

对于编码不够4个码的1、2、3型汉字，其“识别码”的构成及用法将在下面的“取码规则”中介绍（由4个字根或超过4个字根构成的字，是不必加“识别码”的）。


2-5-5-2.htm

（２）二根字及三根字的取码规则

只有2个字根的字，叫“二根字”；只有3个字根的字，叫“三根字”。

“二根字”或“三根字”，其输入编码法是：输入全部字根后，再追加一个“末笔字型识别码”（简称“识别码”）。识别码可以大量减少重码。

以下是简便直观、易学易用的识别码用法（应当在教学中大力提倡！）:

① 对于1型（左右型）字，字根输入之后，补打1个末笔画，就等同于加了“识别码”（为了将识别码与实际的笔画有所区别，我们用带圆圈的笔画表示识别码）。

例如：　　红：　　纟　　工

                  55　　15　 11

                  X　　　A　　G

② 对于2型（上下型）字，字根输入之后，补打“由2个末笔画复合”构成的“字根”，就等同于加了“识别码”。

例如：　　复：　　 　　日　　夂

                  31　　22　　31　 42

                  T　　 J　　　T　　U

③ 对于3型（杂合型）字，字根输完之后，补打由3个末笔画“复合构成”的“字根”，就等同于加了“识别码”。

例如：　　同：　　冂　　一　　口

                  25　　11　 23　13

                  M　　 G　　K　　D

请读者注意：凡“包围型”的字，均以“被包围部分的末笔”，作为整个字的“末笔”来构成“识别码”。

例：“远”的识别码用“元”的末笔“乙”；

    “国”的识别码用“玉”的末笔“丶”；

    “或”的识别码用被“戈”包围部分“口”下边的“一”。

符号说明：以后，我们用笔画加圆圈，代表笔画形式的“识别码”。即：

1区（横区）： －11·G　　 [image] －12·F　　 [image] －13·D

2区（竖区）： －21·H　　 [image] －22·J　　 [image] －23·K

3区（撇区）： －31·T　　 [image] －32·R　　 [image] －33·E

4区（捺区）： －41·Y　　 [image] －42·U　　 [image] －43·I

5区（折区）： －51·N　　 [image] －52·B　　 [image] －53·V

以上共15个符号，作为“笔画形式的识别码”。这一形式，与区位形式、字母形式的识别码完全通用。

例如，“汉”的末笔字型识别码是，意思是1型字，末笔为丶，既可以用“丶”的区位码41表示，也可以用4区1位的字母Y表示， [image] 、41、Y三者作用相同，因为打的是同一个键。

对于带圆圈的“笔画形式的识别码”，实际输入打键时，只打圈里边的笔画就行了。在书写时外带圆圈，只是为了便于与真正的笔画有所区别。


2-6-1-1.htm

１、简码

常用的汉字，除可以按它的全码输入外，多数都还可以只取其最前边的一至三个字根，再加空格键输入。也就是只取其全码的最前边的一个、二个或三个码，再加打空格键（表示输入结束），形成所谓一、二、三级简码，从而提高了输入速度。


2-6-1-2.htm

一级简码（又称“高频字”编码）

将各个字根键打一下，再打一下空格键，便可打出25个最常用的汉字（每键一个）：

一地在要工，上是中国同，和的有人我，主产不为这，民了发以经

如：　　一：11（G）　　的：32（R）　　和：31（T）

25个高频字与键位对应如下图所示：


2-6-1-3.htm

二级简码（只输入全码的前2个码）：

化：亻　　匕　　（34 55，WX）

李：木　　子　　（14 52，SB）


2-6-1-4.htm

三级简码（只输入全码的前3个码）：

想：木　　目　　心　　（14 21 51，SHN）

巍：山　　禾　　女　　（25 31 53，MTV）


2-6-2-1.htm

２、容错码

“容错码”的涵义是：“容易”编错，但“容许”编错的码。容错码的设置，是为了照顾不同的取码习惯，使他们用容易编错的码，照样可以打出所要的字来。“容错码”主要有三种类型： 编码容错、字型容错、定义后缀


2-6-2-2.htm

编码容错

个别汉字的书写笔顺因人而异，致使字根的拆分序列也不尽相同，因而容易弄错。如“长”和“秉”都有多种笔顺：

    长：　丿　　 [image] 　　 [image] 　　 [image] 　　TAYI　　(正确码)

    长：　 　　丿　　 [image] 　　 [image] 　　ATYI　　(容错码)

    长：　丿　　一　　 [image] 　　 [image] 　　TGNY　　(容错码)

    长：　一　　 [image] 　　丿　　 [image] 　　GNTY　　(容错码)


2-6-2-3.htm

字型容错

个别汉字的字型分类不易确定，如：

占：　 　　口　　 [image] 　　HKF　(上下型，正确码)

占：　 　　口　　 [image] 　　HKD　(杂合型，容错码)


2-6-2-4.htm

定义后缀

为了进一步减少甚至杜绝重码，人为地将一些重码字的最后1个码或2个码修改为L（24），或改为有识别能力的字根的做法，叫“定义后缀”。

例如：“喜”与“嘉”重码，输入码都是FKUK。因为“喜”更常用，输入后显示在提示行的第一位，可以默认上屏，相当于不重码，等于“独享”原来的编码FKUK；为了使“嘉”在保留原来编码的同时，也能够“一步到位”上屏，就将最后一码K改为L，使“嘉”也可“独享”一个编码FKUL，这样输入FKUL就只出来“嘉”一个字了。

为什么要改为L而不用别的键呢？是因为以L为最后一码的编码空间冗余太大，又因为L键用右手无名指击键灵活方便。

这些常见重码字的“人工修正码”请见下表：

注:字母下边加圆点“.”者为补加或被修改的编码。


r01

【重码】

几个“五笔字型”编码完全相同的字，叫做重码。当输入一组重码字的编码时，几个重码的字，会同时出现在候选窗口中。

【空码】

“五笔字型”编码中不存在的编码，叫做空码。


2-7-1.htm

词汇输入

在输入词汇时，一律只取4码，单字和词汇可以混合输入，字词之间不用任何换档或附加操作，这叫做“字词兼容”。


2-7-2.htm

2字词编码

取每字全码的前两码组成，共4个码，例如：

生产：　丿　　　　立　　丿

        31　　11　　42　　31　　（TGUT）

经济：　纟　　 [image] 　　氵　　文

        55　　54　　43　　41　　（XCIY）


2-7-3.html

3字词编码

前两个字各取第一码，最后一个字取前两码，共4个码，例如：

电视机：　日　　 [image] 　　木　　几

          22　　45　　14　　25　　（JPSM）

太平洋：　大　　一　　氵

        13　　11　　43　　42　　（DGIU）


2-7-4.htm

4字词编码

每字各取其第一个码，共4个码，例如：

科学技术：　禾　　 [image] 　　扌　　木

            31　　43　　32　　14　　（TIRS）

实事求是：　宀　　一　　十　　日

            45　　11　　12　　22　　（PGFJ）


2-7-5.htm

多字词编码

取第一、二、三及最后一个汉字的第一个码，共4个码，例如：

常务委员会：　 　　夂　　禾　　人

              43　　31　　31　　34　（ITTW）

中华人民共和国：　口　　亻　　人　　囗

                  23　　34　　34　　24　（KWWL）


m86

王码符号双轨输入法

用王码大一统五笔字型软件中的86版五笔字型编码和拼音可以输入各种符号，如下图所示：

注：对于王码零号、王码年份、王码日期、王码月份、王码星期、王码时刻也可以分别采用如下的输入方法：

王码零号ling 王码年份year 王码日期date 王码月份mont 王码星期week 王码时刻time


981-2

【汉字的5种笔画】

1983年王永民教授给“笔画”定义为：

书写汉字时，一次写成的一个连续不断的线段。

由此可推知：

●多个笔画写成的是笔画结构，如“十、口”等，不能叫笔画。

●一个连贯的笔画，不能断开成几段来处理。例如，不能把“申”分解为“丨田丨”，也不能把“里”拆成“田土”等。

经科学归纳，汉字的基本笔画只有下表所示的5种。为了编码，这5种单笔画，分别以数字1、2、3、4、5作为代号：

代 号　　　基本笔画名称　　　笔画走向　　　笔画变形

  1　　　　　横一　　　　　　　左-右

  2　　　　　竖丨　　　　　　　上-下

  3　　　　　撇丿　　　　　　右上-左下

  4　　　　　捺 [image] 　　　　　　左上-右下　　　丶

  5　　　　　折乙　　　　　　　带转折

变形笔画与基本笔画是同一类笔画，这是因为：

（1）由“现”是“王”字旁可知，提笔“ [image] ”实际是横的变形。

（2）由“村”是“木”字旁可知，点笔“丶”应属于“ [image] ”。

（3）由旧体的“木”字其竖笔带钩可知，竖笔向左带钩“ [image] ”应属于竖。

（4）其余一切带转折、拐弯的笔画，都归“折”类。


981-3

【笔画间的三种关系】

汉字笔画之间的结构形态，即构形关系，共有三种：

1.相分离：如“八、小、三”，以及“旦、札、只”的最后一笔；

2.相连接：如“刀、人、几”，以及“广、里、夫”的最后一笔；

3.相交叉：如“十、九、又”，以及“于、中、事”的最后一笔。

笔画之间的三种构形关系，是汉字图形中直观易辨、非常有用的特征信息。在汉字形码中，当仅仅提取笔画结构信息还不足以区分汉字的字形时，就有必要在编码中使用这种“构形信息”。

在98王码中，我们用数字来表示笔画的三种关系，即：

98王码在处理中、日、韩三国字集的21003个汉字的编码时，就用到了上述笔画的构形信息。


981-4

【汉字结构的三个层次】

汉字的最小结构单位是笔画，单笔画有横、竖、撇、捺、折，共5种。

由2个以上单笔画以散、连、交的方式，可以构成笔画结构。笔画结构中成为汉字的，或构字能力较强的结构，在文字学中叫做“字根”或“部件”。汉字的字根或部件，大约有600-1000种。

由字根或部件，用积木组字的方法，可以构成汉字。汉字的字数成千上万：

国标GB2312－80中有6763个汉字；

台湾BIG5字集中有13053个汉字；

国际标准GBK字集中有21003个汉字。

这么多汉字，在文字学中，都可以认为是由“字根”或“部件”组合而成的。

由此可见，汉字结构有三个层次。即：

笔画构成字根（部件）；

字根（部件）构成汉字。

特别提示：笔画、字根（部件）和整字，都只是“文字学”的概念。这些概念和编码学及信息处理中作为编码单元的“码元”，虽有关系，但绝然不是一回事，尤其没有一一对应的关系。


981-5

【汉字的三种字型】

汉字是一种平面图形文字。同样几个码元（字根），摆放位置不同，就可能成为不同的字。如：

“叭”棗“只”

“吧”棗“邑”

可见，码元（字根）的位置关系，也是汉字的一种重要特征信息。这个“字型”信息，在98王码的编码中很有用处。

根据汉字码元（字根）之间的位置关系，我们可以把成千上万的方块汉字分为三种字型：左右型、上下型、杂合型，并顺序命以代号1、2、3，如下表表示。


981-6

【汉字编码与王码】

汉字没有字母，我们不能像输入英文那样，用键盘上的26个字母直接向电脑输入汉字。为此，要将汉字或汉字的构成部分，编成“代号”，也就是“代码”，以便用电脑键盘输入这些代码，间接地输入汉字。

为汉字编制代码的方法，叫“汉字编码”。不考虑读音，完全依据笔画和字形特征，为汉字编制代码的方法叫“形码”。

98王码，即98版五笔字型，是一种形码。

98王码既可以输入国家标准的6763个汉字，也可以输入港台地区的13053个繁体字，以及国际标准GBK大字符集的中、日、韩三国21003个汉字。

98王码完全依字形编码，不受汉字读音和方言的限制，重码很少。在国标GB2312-80字集的6763个汉字中，重码率低于2%，加上简码，平均每打1万个字，才需要挑选一次。即使在GBK字集21003个汉字范围内，重码率也低于5%。

重码率低，是用小键盘实现盲打，提高输入效率的决定因素。


981-7

【汉字编码的单位－码元】

编码是给汉字以及笔画结构编制“代码”，或命名“代号”，就好象给人起名字一样。汉字编码既不涉及书法艺术，更不是“造字法”。

汉字是图形文字，笔画繁多、形态多变。如把几万个汉字分解成较小的块块，即使不细分，分解出来的“字根”或“部件”，也会多达上千种。无论如何，在标准键盘的26个字母键上，是无法摆得下将近1000个符号的。

把汉字理解为“字根”或“部件”，客观上是为汉字设计了“字母”。

然而汉字根本没有，也不可能有字母！

因此，我们不可能，也没有必要以文字学意义上的字根或部件为单位，在键盘上一笔不差地拼出汉字。

98王码中，是以“码元”为单位，向电脑输入汉字的。

我们把笔画结构特征相似，笔画形态及笔画多少大致相同的“笔画结构”，作为编码的“单元”，即编码的“元素”，简称“码元”。

“码元”是一个编码学上的概念，它是指笔画结构的特征，完全不同于文字学意义上的字根或部件。

如“打倒山”、“彐”和“ [image] ”，形态虽略有不同，但有视觉上的相同特征，这三个笔画结构，虽然是三个不同的字根（部件），但我们认为属于同一个“码元”。

其中“彐”有代表性，使用次数多，叫“主码元”，简称“主元”；而使用次数少的“ [image] 、 [image] ”，则叫“次元”，或“副元”。

再如：“水”的同源字形，以及与“水”的笔画特征大致相同的笔画结构，有“ [image] ”等等，合在一起，在编码学中，就可以归为同一码元。其中，“水”叫“主元”，其余的叫“次元”。

总之，“码元”只是编码学意义上的“单元”，是经过抽象的“字根”或“部件”。码元只代表“笔画特征”，而不代表笔画的具体结构和细节。

因此，只要“特征”相同，笔画的细节尽管不一样，也并不影响它们是同属一个“码元”。

例如：“ [image] ”就是同一码元。

很明显，它们的共同“特征”是“笔画向下构成一个罩”，这里，“ [image] ”是“主元”，“ [image] ”是“次元”。

98王码的“码元”除5个单笔画外，“主元”有150个，“次元”有90个。

最后，为了学好用好98王码，我们必须反复强调，“码元”完全不同于文字学意义上的“字根”或“部件”。

“码元”只是我们为了给无比复杂的汉字编制代码，命名代号。我们把曲直长短略有不同，但总体形似的笔画结构归为同一码元。

字根或部件，是作为汉字的构成部分，不可以随意改动变形的，否则就“不是那个字”了。

理清文字学中“字根”与编码学中“码元”的概念混淆，对于消除长期以来不同学科之间的相互非难和误解，对于融多学科之长用于编码研究，具有深刻的理论意义和重要的现实意义。


981-8

【码元顺序与笔顺规范】

码元是指汉字笔画结构的“特征”。一个较复杂的汉字，常有一系列的结构“特征”。当把几个“码元”用于编码时，为便于教学和应用，其码元的序列最好与汉字的书写顺序保持一致。如：

新：立　木　斤 （正确）

    立　斤　木 （错误）

刀：刀 [image] 丿 （正确）

    刀　丿 [image] （错误）

另外，笔画既不能任意切断，也不能重复使用，在两个码元中出现如：

里：日　土 （正确）

    田　土 （错误）

一般来说，一个汉字的码元顺序和笔画顺序是一致的，大多数情况下，码元顺序也与书写汉字时字根（部件）的顺序相一致。

但也有例外的情况。

1、码元顺序与笔顺不一致。例如：

“ 国 ”字的最后一笔,也即“ [image] ”的最后一笔。但“国”的第一个码元“ [image] ”，却把最后一笔“带”走了。

再如“或”，第一个码元是“ [image] ”，却把最后的两个笔画带到第一个码元中了。

可见，“编码”不是书法。为了照顾码元的完整性和直观性，有时候就无法遵照“笔顺规范”。

2、码元顺序与汉字部件结构的顺序不一致。例如：

“ 武 ”字的码元顺序是： （编码顺序）

“ 武 ”字的规范笔顺是： （书写顺序）

由此，我们可以看到，码元和字根（部件）确有不同之处。


982-1

五笔字型键盘的各区字根

第1区－横起笔

主要是横起笔的第一区码元，键位及助记词如下所示：


982-2

第2区－竖起笔

主要是竖起笔的第二区码元，键位及助记词如下所示：


982-3

第3区－撇起笔

主要是撇起笔的第三区码元，键位及助记词如下所示：


982-4

第4区－点起笔

主要是点起笔的第四区码元，键位及助记词如下所示：


982-5

第5区－折起笔

主要是折起笔的第五区码元，键位及助记词如下所示：


982-2-1

【各区的5个键位】

王码键盘的每一个区，各有5个键位。区号从1到5，位号也是从1到5，区位号组合共形成5×5=25个代码，作为各个键位的代号、代码，也即编码。对应到标准键盘Z键以外的25个键上就是：

各区的位号，都从键盘的中部，向两端排列，这样就使得双手放到键盘上时，位号的顺序与食指到小指的顺序相一致。

这就是5区5位的王码（五笔字型）键盘。


982-3-1

【王码键盘键面符号介绍】

王码键盘的各个键面上，有以下几类符号。现以第1区第5位15（A）键为例，介绍如下：

键名，每个键上左上角打头的那个主码元，都是构字能力很强，或者有代表性的汉字。这个汉字，叫做键名字，简称“键名”。

主码元，是各键上代表某种汉字结构“特征”的笔画结构。如“ [image] 、七、艹”等。

次码元，是具有主码元的特征，不太常用的笔画结构。

编码时，为了直观地提示编码（仅仅是提示！），帮助记忆，我们常常用“码元”直接表示编码，也可以用“主码元”代表“次码元”。

因此，当你把“码元”当成“字根”（部件），与汉字结构一一对照时，难免会发现差异。这是不奇怪的。因为“编码”既不是书法艺术，也不是“造字法”！这里的“码元”不是汉字的实际构成部分，只是结构特征代表的“符号”。

由上图1区5位的A键可见，第1区的第5个键位上，有5个主码元：

      工　 [image] 　艹　 [image] 　七

另有7个次码元：

A键的代码，即A键上全部码元的编码，都由区号1，位号5组成，也即用15，或A代表这个键上的全部码元。

以后，我们就以15或A来作为A键上所有码元的代码，为汉字编码；只是在个别情况下，为了提示编码，才用码元，甚至字根（部件）来直观地提示一下。


984-1

【快速记住码元的区位号】

（1）区号与首笔代号一致：

区号一般与码元第一个笔画的代号一致。

（2）许多位号与次笔代号一致：

键盘设计中，我们尽量让码元的位号与第2个笔画的代号一致。

为此，大部分码元，只要用笔画代码“读”它的前2个笔画，就构成了码元的“区位号”（记住这个区位号，就是编码！）。

现示例如下：

当然，全部按码元的前2个笔画去找码元的键位，有些情况也不灵。特别是找“次元”。

如“ [image] ”前2个笔画是35，可它就不在3区5位，因它跟“主元”“ [image] ”具有同一特征，二者都在25M键上。

“主元”表明特征，“头头儿”。而“次元”附属于“主元”，编码相同。

除了“水”、“火”之外，其它各键的主元，一般都不会跑出首笔所在的区。根据主元，顺藤摸瓜，可立即找到次元。


982-6-1

98版五笔字型简体字根键位图


982-6-2

98版五笔字型简繁体字根键位图


983-1

【“98王码”汉字编码流程图】

这张一目了然的图表，是“98王码”编码的“总路线”，编码的方法和规则尽在其中。


983-2-1

【键名汉字输入】

码元之中，有的是汉字，有的不是汉字。每个键上左上角的那个码元，即助记词中的第一个汉字，叫“键名”码元，或“键名”汉字，简称“ 键名 ”。

键名的输入法是：把所在的键连打4下，如：

1区1位键名：王　11　11　11　11　　（GGGG）

3区2位键名：白　32　32　32　32　　（RRRR）

4区5位键名：之　45　45　45　45　　（PPPP）

5区3位键名：女　53　53　53　53　　（VVVV）


983-2-2

【成字码元输入】

除键名以外，凡本身是汉字的码元，叫“ 成字码元 ”。其输入法是：先打一下它所在的键（ 这一下俗称“报户口” ），再打第一个、第二个及最末一个单笔画，共4下，不足4下，补一个空格键：

4区1位的成字码元：文：文 丶 一

41 41 11 41 （YYGY）

1区5位的成字码元：七：七 一

15 11 51 （AGN）（不足4码，补空格键1下）

3区3位的成字码元：毛：毛 丿 一

33 31 11 51 （ETGN）

3区4位的成字码元: 亻：亻 丿 丨

34 31 21（WTH）（不足4码，补空格键1下）

4区3位的成字码元：氵：氵 丶 丶

43 41 41 11 （IYYG）（提笔 [image] 等于横笔）

注意：“码元”本来只是代表笔形结构的“特征”，只有当一个“码元”完全等同于一个汉字时，它才可以作为“成字码元”输入电脑。

在98王码中，键名码元有25个。

1区：王土大木工

2区：目日口田山

3区：禾白月人金

4区：言立水火之

5区：已子女又幺

成字码元（包括平时不作为汉字、但有国标码的偏旁部首），计有100多个。其中本身是常用汉字的66个如下：

1区：五夫干士十二寸未甘雨犬三 [image] 古石厂丁西甫七 [image] （21个）

2区：上止早虫川甲四车由贝（10个）

3区：斤丘气手用力毛八几夕儿（11个）

4区：文方辛六羊门小业广米（10个）

5区：心尸羽耳了也乃皮刀九巴母弓匕（14个）

练习：请逐个写出以上“成字码元”的输入码：

示例：也： 也 [image] 丨

52 51 21 51 （BNHN）


983-2-3

【补码码元及其输入】

参与编码时，要编两个码的码元叫“ 补码码元 ”，也叫双码码元。98王码中的补码码元共有以下3个：

表中带圆圈的笔画，是“补码”的笔画表示形式，作为一个符号，用以提示编码。

编码示例：

获：15　35　31　13　（AQTD）

    艹　犭　 [image] 　犬　（编码提示）

社：45　41　12　11　（PYFG）

    礻　 [image] 　土　 [image] 　（编码提示）


983-3-1

合体字的输入

凡是"字根总表"上没有的汉字，也即"键外字"，都可以认为是由字根和笔画拼合而成的，这类字我们称之为"合体字"或“多元字”。


983-4-1

一、规范笔顺

“合体字”编码，一般情况下，要按照正确的书写顺序进行。如：

新：立　木　斤　（正确，符合规范书写顺序）

    立　斤　木　（错误，未按书写顺序编写）

中：口　丨　　　（正确，符合规范书写顺序）

    丨　口　（错误，未按书写顺序编写）

夷：一　弓　人　（正确，符合规范书写顺序）

    大　弓　（错误，未按书写顺序编写）

非：丨　三　丨　三　（正确，符合规范书写顺序）

    三　 [image] 　三　　（错误，未按书写顺序编写）


983-4-2

二、取大优先

“取大优先”，也叫做“优先取大”。按“书写顺序”为汉字编码时，不能无限制地采用笔画少的码元。否则，汉字都将变成单笔画码元了!

要以“ 再添一个笔画，便不能构成为笔画更多的码元 ”为限度，每次都以那个“ 尽可能大 ”的，即“尽可能笔画多”的结构特征作为码元编码。例：

世：　第一种：一　凵　乙　(误)

      第二种：廿　乙　　(正)

显然，前者是错误的，因为其第二个码元“凵”，完全可以向前“凑”到“一”上，形成多一个笔画的码元“廿”。再如：

甩： 第一种： 　(误)

     第二种：月 [image] 　　(正)

同样，第一种编码是错误的。因为其第二码的“二”，完全可以向前“凑”成“更大”一点的码元“月”。

“取大优先”，俗称“尽量往前凑”，是一个在汉字取码时“最常用到的基本规则”。

至于什么才算“大”，“大”到什么程度才到“边”，等到读者熟悉了码元总表，你便不难发现，这个“限度”，这个“边”，无非是码元总表中可以“凑”成的“笔画最多，又符合码元特征”的笔画结构罢了!


983-4-3

三、兼顾直观

在确认码元时，为了使码元特征明显易辩，有时就要“牺牲”“书写顺序”和 “取大优先”的原则，形成个别例外的情况。

例1：国

按“书写顺序”，其码元应是：“冂 王丶一”；但这样编码，不但有悖于该字的字源，也不能使码元“囗”直观易辩。我们只好违背“书写顺序”，按“囗王丶”的顺序编码。

例2：自

按“取大优先”编码为：“亻 [image] 三”；但这样，不仅不直观，而且也有悖于“自”字的字源(有人说，这个字的字源是“一个手指指着鼻子”，这里的“目”是鼻子的象形)。我们只能按“丿目”编码，这样的编码叫“兼顾直观”。

例3：戋

二丶 [image] （取大优先）

一　 [image] （兼顾直观）

显然，按后者编码，更能符合码元的笔画特征。


983-4-4

四、能连不交

请看以下取码实例：

失：　丿　夫　(二者是相连的)　（正）

         大　(二者是相交的)　（误）

朱：　丿　未　(二者是相连的)　（正）

         木　(二者是相交的)　（误）

当一个字既可以视作“相连”的几个码元，也可视作“相交”的几个码元时，我们认为“相连”的情况是可取的。因为一般来说，“连”比“交”更为“直观”，更能显现码元的笔画结构特征。


983-4-5

五、能散不连

在第一章中我们讲过，笔画和字根之间，字根与字根之间的关系，可以分为“散”的关系、“连”的关系和“交”的关系三种。相应地，码元之间也有这样的三种关系。如：

倡：三个码元之间是“散”的关系；

自：首笔“丿”与“目”，两个码元之间是“连”的关系；

夷：“一”、“弓”与“人”，三个码元是“交”的关系。

几个码元之间的关系，是决定汉字字型的主要依据。

汉字的字型，依其码元之间的关系，如第一章基础知识中所讲，可以分为左右型（代号1）、上下型（代号2）、杂合型（代号3）。

几个码元都“交”“连”在一起的，如“夷”、“丙”等，便肯定是“杂合型”，属于3型字，不会有争议。

然而值得注意的是，有时候，一个汉字的几个码元，都不是单笔画，这些码元之间的关系，常常在“散”和“连”之间模棱两可。如：

占： 口，两个码元按“连”处理，便是杂合型(3型)；如按“散”处理，便是上下型(2型)。

矢： 大，两个码元如果按“连”处理，“矢”便是杂合型(3型)；两个码元如果按“散”处理，“矢”便是上下型(2型)。

当遇到这种既能“散”，又能“连”的情况时，我们规定：

只要不是单笔画，一律按 “能散不连”判别，即作为散的关系。

因此，以上两例中的“占”和“矢”，都被认为是“上下型”字(2型)。

作出以上这些规定，可能与文字结构学或字源学上的说法不相一致，这并不重要，因为这里只是“编码”，不是造字，更不是书法艺术。编码中的这种规定，仅仅是为了避免取码的二义性，并保证编码体系的严密和完整。人们大可不必认为，作者是要求你从今以后把“占”和“矢”写成上下分离的两个部分。

实际上，用得上后3条规定的字，只是极少数。


983-5-1

【多元字的取码规则】

所谓“多元字”，是有4个以上码元的字。这种字，不管实际上有几个码元，我们仅仅“按书写顺序将第一、二、三及最末一个码元编码”，俗称“一二三末”，共编四个码。如：

戆：立 早 夂 工 贝 心 (42 22 31 51)

U J T N

爨：臼 冂 一 口 冖 木 木 大 火 (33 25 11 44)

E M G O


983-6-1

【四元字的取码规则】

“四元字”是指刚好有四个码元特征的字。其取码方法是“依照书写顺序将四个码元编码” ：

照：日　刀　口　灬　（22 53 23 44）　JVKO

低：亻　 [image] 　 [image] 　丶　（34 35 15 41）　WQAY

驿： 　一　又　 [image] 　（54 11 54 11）　CGCG


983-7-1

【二元字和三元字的取码规则及识别码】

只有2个码元的字，叫“二元字”；

只有3个码元的字，叫“三元字”。

当一个字的码元少于4个时，即“二元字”或“三元字”，其输入编码法是：

输入全部码元后，再追加一个 “末笔字型识别码” (简称“识别码”)。

“识别码”是由“末笔”代号加“字型”代号，构成的一个复合附加码。

一．识别码的由来

在7000来个汉字中，大约有10%的汉字，只有2个码元。如：“红、计、要、他”等。把这些字的2个码元编码，其编码长度为2(即2个码)。可是，98王码即（五笔字型），是用25个键来输入汉字的。这样，只用25个键，打2下作为一个汉字的码，充其量可以组成25×25=625个编码，即两码的编码空间是625。

这就相当于，我们只有625个房间号，要住700个人!

这就难免产生拥挤。何况，并不是每一种组合都能对应一个汉字。因此，许多“房号”永远是“空号”，不可能有字，势必使剩余的“房间”更加拥挤不堪——产生大量重码(字不同，但它们的编码相同叫“重码”)!

“重码”字太多，输入时，需要选字，像汉语拼音输入一样，打一组键，有许多个字显示出来，不能盲打，必然降低输入效率，是我们不希望的。何况，这些二元字，大都是最常用的字呢?

因此，必须把它们的编码离散——区分开来。

办法是在码元的后边，再补加一个码元。

为此，我们规定：二元字及三元字，码元输入之后，后边一律再加上一个码——“识别码”。

这样，可以大幅度减少常用字的“重码”，从而提高输入效率。

“末笔字型识别码”为减少重码起了关键作用，使得绝大多数原本“重码”的常用字，都有一个与该字对应的唯一编码，而不再“重码”了。

二、“识别码”的必要性及构成

以下例子可以进一步说明增加“识别码”的必要性。

1.丢失字型信息会引起重码

    叭： 口　八　(KW)　(1型字)

    只： 口　八　(KW)　(2型字)

    吧： 口　巴　(KC)　(1型字)

    邑： 口　巴　(KC)　(2型字)

    旮： 九　日　(VJ)　(2型字)

    旭： 九　日　(VJ)　(3型字)

以上三组汉字，都成了重码字。

如果有办法将以上三组汉字的“字型”特征，作为一个编码补在后边，这些字就都不再重码了。

2.因同一个键位上有几个不同的码元而引起重码

    沐： 氵 木　(IS)　(末笔为 [image] )

    汀： 氵 丁　(IS)　(末笔为｜)

    洒： 氵 西　(IS)　(末笔为一)

    他： 亻 也　(WB)　(末笔为 [image] ，1型字)

    仓： 人　 [image] 　(WB)　(末笔为 [image] ，2型字)

    仔： 亻 子　(WB)　(末笔为一，1型字)

以上2组汉字，都是重码字。

如果将这些字的“末笔”特征作为一个编码补加在后边，这些字则无一重码。 “五笔字型”中设计的“末笔字型识别码”，是一个既含有“末笔”信息，又含有“字型”信息的一个“综合功能码”。在以上例子中，只要在码元之后加上“识别码”，就不会有重码了。

“识别码”是“五笔字型”仅仅使用25个键位，又有极少重码的关键性技术。


983-8-1-1

【简码输入】

为了减少击键次数，提高输入速度，一些常用的字，除按它的全码可以输入外，多数都还可以只取其最前边的一至三个码元，再加空格键输入之，即只取其全码的最前边的一个、二个或三个码，再加打空格键表示输入结束，形成所谓一、二、三级简码。

一级简码(又称高频字码)：

将各键打一下，再打一下空格键，即可打出25个最常用的汉字(每键一个)：

一地在要工　上是中国同　和的有人我　主产不为这　民了发以经

如:　　一：　11(G)　　　要：　14(S)

      的:　　32(R)　　　和：　31(T)

二级简码（只输入全码的前2个码）：

      化：　亻　匕　（34　55　WX)

      玉：　王 丶 （11　44　GY）

      李：　木　子　（14　52　SB)

      乡: 　 　丿　（55　31　XT)

      能：　厶　月　（54　33　CE）

三级简码（只输入全码的前3个码）：

      华:　亻　匕　十　(34　55　12　WXF)

      想:　木　目　心　(14　21　51　SHN)

      得：　彳　日　一　(31　22　11　TJG)

      巍：　山　禾　女　(25　31　53　MTV)

有时，同一个汉字可有几种简码。例如"经"，就同时有一、三级简码及全码等三个输入码：

      经：　55　(X)

      经：　55　54　15　(XCA)

      经：　55　54　15　11　(XCAG)


983-8-1-2

【容错码】

什么叫“容错码”?“容错码”有两个涵义：

其一是容易搞错的码；

其二是容许搞错的码；

“容易”弄错的码，“容许”你按错的打，谓之“容错码”。

“五笔字型”输入技术中的“容错码”设计了将近1000个，使用者还可以自己再建立。“容错码”主要有以下两种类型：

编码容错

个别汉字的书写顺序因人而异，致使码元的序列也不尽相同，因而容易弄错者，如：

秉： 丿 一 彐 小　(容错码)

秉： 禾 彐　 [image] 　(正确码)


983-9-1

【词语输入规则】

1983年元月，“五笔字型”首创了汉字词语的依形编码，以及字码、词码码长相同、体例一致的实用化词语输入法。在输入词语时，一律取等长四码，而且单字和词语可以混合输入，其间不用任何换挡或其它附加操作，谓之“字词兼容”。其编码方法为：

一、2字词

取每字全码的前两码组成，共四码。

经济： 纟 [image] 氵 文 ( 55 54 43 41)

X C I Y

国际： 囗 王 阝 二 ( 24 11 52 12)

L G B F

二、3字词

前两字各取一码，最后一字取两码，共四码。

计算机： 讠 [image] 木 几 ( 41 31 14 34)

Y T S W

三、4字词

每字各取其第一个码，共4个码，例如：

科学技术： 禾 [image] 扌 木

31 43 32 14 （TIRS）

四、多字词

取第一、二、三及最后一个汉字的第一个码，共4个码，例如：

常务委员会： 夂 禾 人

43 31 31 34 （ITTW）

中华人民共和国： 口 亻 人 囗

23 34 34 24 （KWWL）


m98

王码符号双轨输入法

用王码大一统五笔字型软件中的98版五笔字型编码和拼音可以输入各种符号，如下图所示：

注：对于王码零号、王码年份、王码日期、王码月份、王码星期、王码时刻也可以分别采用如下的输入方法：

王码零号ling 王码年份year 王码日期date 王码月份mont 王码星期week 王码时刻time


D1-1

五笔字型输入法的特点

“五笔字型”是一种高效率的汉字输入法，是只使用25个字母键，在键盘上按照汉字的笔画结构（码元）向电脑输入汉字的方法。这一输入法，有以下特点：

①纯形编码，重码少。适合专职和非专职人员共同使用，是不管读音，完全按字形编码的方法，编码不受方言及是否认识的限制，编码的唯一性强，平均每输入10000个汉字，才有1～2个字需要人工挑选。因此，是目前世界上效率最高的汉字键盘输入法。

②十指打键，效率高。“五笔字型”用双手10个手指打键。经过标准的指法训练，每分钟向电脑中输入100个字很是平常。1998年“京城五笔字型大奖赛”，冠军的速度是在错1罚5的严厉评判规则下，每分钟输入生稿293个汉字。

③字词兼容。用“五笔字型”既能输入单字，还能输入词汇。无论多么复杂的汉字最多只打4下键，无论多长的词汇也只打4下键。字与词之间，不要任何转换或附加操作，既符合汉字构词灵活、语句中字词很难切分的特点，又能大幅度地提高输入速度。

④越打越顺手。“五笔字型”依照“形码设计三原理”研究完成，码元的组合符合“相容性”——使重码最少；键位安排符合“规律性”——使字根易记易学，而指法设计的“谐调性”——使得各个手指的击键负担趋于合理，打起来顺手，越打越顺手。

⑤全国通用。“五笔字型”经过了18年之久的大规模社会实践的检验，已成为在国内占主导地位的汉字输入技术，所以，具有很好的通用性：学会了“五笔字型”，到处都有现成的电脑可供使用；厂家的电脑类产品装入了“五笔字型”，全国乃至世界各地都有成百上千的人不经训练便会操作。

你若要想事先“感受”一下用“五笔字型”输入汉字的情景和乐趣，请顺序按一下含有“日、刀、口、灬”的四个键，便可输入一个“照”字。你不妨开机试试。你可能立即有两个问题：

①每个键上那么多部件（字根），为什么只有“日、刀、口、灬”起作用？为何不会出来别的字？

②那么多部件（字根），怎么能记住呢？

学习以下内容，你便可明白其中的道理并学会五笔字型输入法。


D1-2

汉字的5种笔画

字根是由笔画写成。笔画、字根（部件）、整字，是汉字结构的三个层次。

1984年王永民教授给笔画定义为：书写汉字时，一次写成的一个连续不断的线段。

由此可以推知：

⑴两笔写成的，不能叫笔画，例如“十、口”等，它们只能叫“笔画结构”。

⑵一个连贯的笔画不能断开。例如不能把“申”分解为“丨田丨”等。

笔画的分类，困扰学术界久矣！分10种、16种、24种、36种者有之，分8种、5种、4种、3种者有之，五花八门，众说纷纭。

科学是一个过程，科学自有规律。

科学的结论是：按照书写方向划分笔画的类型，如下图所示，则只有5种——横、竖、撇、捺、折。前4种是单方向的笔画，“折”则代表一切带转折、拐弯的笔画。为了便于记忆和排序，我们分别用1、2、3、4、5命名5种笔画的代号：

人们要问：笔画“点”和“提”到哪里去了？

以下例子可作为这张表的补充说明：

（1）“提笔”等于“横”：王　现

（2）“点”等于“捺”：木　村

（3）“竖左钩”等于“竖”： 　禾

（4）所有带转折的笔画都算作“折”。

为便于书面表示，以后所有的“折”笔，不管怎么“折”，怎么“弯”，怎么“拐”，一律都有“乙”来表示，其笔画代号都是5。

给笔画分类，并命名以数字代号，是学习王码输入法时最重要的基础知识。在实践中，许多人之所以编码出现错误，或对键盘上码元排列的规律性“视而不见”，其根本原因，常是因为没有掌握好五种单笔画的分类及其数字代号。


D1-3

汉字的3种字型

习惯上，我们把构成汉字的基本笔画结构，称作“字根”或“部件”。而当“字根”或“部件”用于编码的时候，又可以把它们叫做“码元”，意思是编码的“元素”。

汉字是一种平面文字，同样几个字根，同样的先后顺序，摆放的位置不同，就是不同的字。如：

叭——只　　　　吧——邑

呐——呙　　　　岂——屺

可见，字根相互间的位置关系，也是汉字图形的一个特征，在汉字编码中，用数字代表这个特征，就成为很有用的、用以分区“重码”的“识别”信息。

根据构成汉字的各个字根之间的位置关系，我们可以把成千上万的方块汉字，分为三种字型：

左右型：字根左右排列。

上下型：字根上下排列。

杂合型：字根互相周围或交叉套迭。

现在，我们根据各种字型拥有汉字的多少，顺序将字型命以数字代号，如下表所示。

从此以后，我们便约定：

1型字，即指“左右型”汉字，其代号为1；

2型字，即指“上下型”汉字，其代号为2；

3型字，即指“杂合型”汉字，其代号为3。

将来，我们给汉字编码时，字型及其代号将非常有用。

这里应当说明，以后我们也会学到，在王码中，仅仅对于那些由2个或3个字根组成的字，我们才关心它的“字型”。如果一个字由4个或4个以上的字根组成，例如：编码中，我们就不再计较是什么“型”了。


d2-1-1

五笔字型键盘的各区字根

第1区－横起笔

主要是横起笔的第一区码元，键位如下所示：


d2-1-2

第2区－竖起笔

主要是竖起笔的第二区码元，键位如下所示：


d2-1-3

第3区－撇起笔

主要是撇起笔的第三区码元，键位如下所示：


d2-1-4

第4区－点起笔

主要是点起笔的第四区码元，键位如下所示：


d2-1-5

第5区－折起笔

主要是折起笔的第五区码元，键位如下所示：


D2-3-1

王码键盘的区位号规律

在王码中，码元在键盘上的分布是有规律的：

⑴区号与码元的首笔代码一致。

⑵位号基本上与码元的次笔代码一致。例如：

⑶一、丨、丿、丶、乙都在相应区的第1位；

  二、 [image] 、 [image] 、 [image] 、 [image] 都在各区的第2位；

  三， [image] 、 [image] 、氵、 [image] 都在各区的第3位；

       、　　灬都在相应区的第4位。


D2-4-1

5区25位的王码键盘

汉字是由字根（码元）构成的，如“李”字是由码元“木”和码元“子”组成。输入“李”字时，就要依次打一下码元“木”和码元“子”所在的键，好像在电脑拼合成了一个“李”字。

作者将构成汉字的字根，也即用于给汉字编码的“码元”，优选归纳为125种，按它们首笔或次笔的笔画代号，分配在除Z键以外的25个英文字母键上，形成了86王码的“码元键盘”。

王码键盘分为5个区，区号从1到5；每一个区，各有5个键位，位号也是从1到5，从键盘中部向左右两端排列；区位号组合，共形成5×5=25个代码11，12……54，55。每个区位号分别与一个英文字母相对应，它们的对应关系是：

    横起笔的码元，主要在第1区——王土大木工　等；

    竖起笔的码元，主要在第2区——目日口田山　等；

    撇起笔的码元，主要在第3区——禾白月人金　等；

    点起笔的码元，主要在第4区——言立水火之　等；

    折起笔的码元，主要在第5区——已子女又纟　等。


D2-5-1

码元键位图

一、新世纪版五笔字型简体字根键位图

二、新世纪版五笔字型繁体字根键位图


D3-2-1

键名汉字输入

键名的输入法是：把所在的键连打4下。

例如：

1区1位键名：王 11　11　11　11　（GGGG）

3区2位键名：白 32　32　32　32　（RRRR）

4区5位键名：之 45　45　45　45　（PPPP）

5区3位键名：女 53　53　53　53　（VVVV）

在王码五笔字型中，键名码元有25个。

    1区：王土大木工

    2区：目日口田山

    3区：禾白月人金

    4区：言立水火之

    5区：已子女又纟


D3-2-2

成字码元输入

除键名对外，凡本身是汉字的码元，叫“成字码元”。其输入法是：先打一下它所在的键（这一下俗称“报户口”），再打第一个、第二个及最末一个单笔画，共4下，不足4下，补一个空格键。

例如：

七：七 一 乙（不足4码，补空格键1下）

亻：亻 丿 丨（不足4码，补空格键1下）


D3-2-3

补码码元及其输入

参与编码时，要编两个码的码元叫“补码码元”，也叫双码码元。86王码中的补码码元共有3个（其中“食”仅用在繁体字中）：

注 ：表中带圆圈的笔画 [image] 、 [image] 等，是“补码”的笔画表示形式，作为一个符号，用以提示编码。


D3-3-1

合体字的取码规则

凡是“码元总表”上没有的汉字，即“键外字”，都可以认为是由码元对应的字根拼合而成的，这类字我们称之为“合体字”或“多元字”。

一、书写顺序

“合体字”编码，一般情况下，要按照正确书写顺序进行。

例如：

新：立　木　斤（顺序正确）

    立　斤　木（顺序错误）

二、取大优先

要以“再高添一个笔画，便不能构成为笔画更多的码元”为限度，每次都以那个“笔画尽可能多”的结构作为码元。

例如：

失： 　人（正确）

       大（错误）

注：“取大优先”，俗称“尽量往前凑”，是一个在汉字取码时最常用到的基本规则。

三、兼顾直观

在编码时，为了使码元特征明显易辨，有时就要暂时牺牲“书写顺序”和“取大优先”的原则，形成个别例外的情况。

例：“国”字

按“书写顺序”，其码元应是：“冂王丶一”，但这样编码，不但有悖于该字的字源，也不能使码元“囗”直观易辨。我们只好违背“书写顺序”，按“囗王丶”的顺序编码。同样的例子又如：

自：丿　目　（正确）

    亻　 [image] 　三　（错误）

四、能连不交

请看以下取码实例：

天：一　大　（正确）

    二　人　（错误）

生：丿　 [image] 　（正确）

       土　（错误）

一般来说，“连”比“交”更为“直观”，更能显现码元的笔画结构特征，更易于辨认。

五、能散不连

有时候，一个汉字的几个码元，都不是单笔画，这些码元之间的关系，常常在“散”和“连”之间模棱两可。

如：

占： 　口，两个码元按“连”处理，便是杂合型（3型）字，如按“散”处理，便是上下型（2型）字。

矢： 　大，两个码元按“连”处理，“矢”便是杂合型（3型）字；两个码元如果按“散”处理，“矢”便是上下型（2型）字。

又如：羊： 、

      午： 、十。

都是既可“连”，又可“散”的关系。

当遇到这种既能“散”，又能“连”的情况时，我们规定：只要不是单笔画，一律按“能散不连”判别，即优先确定为“散”的关系。

由此可见，以上两例中的“占”和“矢”，都被认为是“上下型”，即作为2型字。


D3-3-2

"多元字"的取码规则

所谓"多元字"，是有4个以及4个以上码元的字。这种字，我们仅仅"按书写顺序取第一、二、三及最末一个码元编码"，俗称"一二三末"，共编四个码。例如：

暨：彐 厶 匚 儿 日 一

53 54 15 11

V C A G


D3-3-3

"四元字"的取码规则

"四元字"是指刚好有四个码元的字。其取码方法是"依照书写顺序将四个码元编码"。

例如：

照：日 刀 口 灬

22 53 23 44

J V K O

低：亻 [image] [image] 丶

34 35 15 41

W Q A Y

重：丿 一 日 土

31 11 22 12

T G J F

事：一 口 彐 亅

11 23 53 21

G K V H


D3-3-4

二元字和三元字的取码规则及识别码

1. 末笔字型识别码

必要性之一—因码元相同，字型不同引起重码：

叭：口 八（23　34　KW）

只：口 八（23　34　KW）

这个例子说明，编码中丢失了字型信息，才产生了重码。

必要性之二—因几个字根同一键位引起重码：

沐：氵 木（43　14　IS）

汀：氵 丁（43　14　IS）

洒：氵 西（43　14　IS）

这个例子说明，编码没有将“木、丁、西”加以区分，才产生了重码。

由以上例子可知，为了避免几个字的编码相同（重码），既有必要提取字型信息，又有必要从同一键位的字根上提取笔画特征信息用于编码，复合这两种信息就是“识别码”。

“识别码”是由“末笔”代号加“字型”代号构成的一个“复合附加码”。1 、2、3型字的识别码用法如下：

2. 取码规则

只有2个码元的字，叫“二元字”；只有3个码元的字，叫“三元字”。

“二元字”或“三元字”，其输入编码法是：输入全部码元后，再追加一个“末笔字型识别码”（简称“识别码”）。识别码可以大量减少重码。

⑴ 对于1型（左右型）字，码元输入之后，补打1个末笔画，就等同于加了“识别码”。（为了将识别码与实际的笔画有所区别，我们用带圆圈的笔画表示识别码）

例如：

红：纟　工

    55　15　11

    X　　A　　G

形：一

    11　15　33　31

    G　　A　　E　T

⑵ 对于2型（上下型）字，码元输入之后，补打由2个末笔画“复合构成”的“码元”，就等同于加了“识别码”。 例如：

字：宀　子

    45　52　12

    P　　B　　F

复：　日　夂

    31　22　31　42

    T　　J　　T　　U

花：艹　亻　匕

    15　34　55　52

    A　　W　　X　　B

⑶ 对于3型（杂合型）字，码元输完之后，补打由3个末笔画“复合构成”的“码元”，就等同于加了“识别码”。　例如：

同：冂　一 　口

    25　11　23　13

    M　　G　　K　　D

远：二　儿　辶

    12　35　45　53

    F　　Q　　P　V

局：尸　 [image] 　口

    51　51　23　13

    N　　N　　K　　D

朱： 　小

    32　43　43

    R　　I　　I

夷：一　弓　人

    11　55　34　43

    G　　X　　W　　I

（注意：凡“包围型”的字，均以被包围那个部分的“末笔”作为整个字的“末笔”来构成识别码）


D3-4-1

简码输入

一些常用的字，除按它的全码可以输入外，多数都还可以只取其最前边的一至三个码元，再加空格键输入之，即只取其全码的最前边的一个、二个或三个码，再加打空格键表示输入结束，形成所谓一、二、三级简码，从而提高了输入速度。

1. 一级简码（又称高频字码）

将各键打一下，再打一下空格键，即可打出25个最常用的汉字（每键一个）：

一地在要工　上是中国同　和的有人我　主产不为这　民了发以经

如：一：11（G）　　　的：32（R）　　　和：31（T）

2. 二级简码（只输入全码的前2个码）：

化：亻 　匕（34 　55 　WX）

李：木 　子（14 　52 　SB）

3. 三级简码（只输入全码的前3个码）：

想：木 　目 　心（14 　21 　51　SHN）

巍：山 　禾 　女 (25 　31 　53　MTV)


D3-4-2

二、容错码

“容错码”的涵义是：“容易”而且“容许”编错的码。容错码的设置，是为了照顾个别人与他人不同的取码习惯，使他们用容错码一样可以打出容易搞错的字。

例如：

拌：扌 　丷　　 [image] 　（正确）

    扌 　丷 　　二 　　丨 （容错）


D3-5-1

词汇输入

在输入词汇时，一律只取4码，而且单字和词汇可以混合输入，字词之间不用任何换档或其它附加操作，叫做“字词兼容”。其编码方法为：

一、2字词

取每字全码的前两码组成，共4码。

例如：

生产：丿　　立　丿

      31　11　42　31（TGUT）

经济：纟　 [image] 　氵　文

      55　54　43　41（XCIY）

建设：彐　二　讠　几

      53　12　41　34（VGYW）

世界：廿　 [image] 　田　人

      15　51　24　34（ANLW）

二、3字词

前两个字各取第一码,最后一字取前两码,共4码。

太平洋：大　一　氵

        13　11　43　42　（DGIU）

委员会：禾　口　人　二

        31　23　34　12（TKWF）

新加坡：立　力　土

        42　33　12　21（UEFH）

红楼梦：纟　木　木　木

        55　14　14　14（XSSS）

三、4字词

每字各取其全码的第一码，共4码。

例如：科学技术：禾　 [image] 　扌　木

                31　43　32　14（TIRS）

精心安排：米　心　宀　扌

          44　51　45　33（ONPR）

四、多字词

取第一、二、三及末一个汉字的第一码，共4码。

例如：常务委员会：　夂　禾　人

                  43　31　31　34（ITTW）

中华人民共和国：口　亻　人　囗

                23　34　34　24（KWWL）

中国人民解放军: 口　囗　人　冖

                23　24　34　45（KLWP）


m20

王码符号双轨输入法

用王码大一统五笔字型软件中的新世纪版五笔字型编码和拼音可以输入各种符号，如下图所示：

注：对于王码零号、王码年份、王码日期、王码月份、王码星期、王码时刻也可以分别采用如下的输入方法：

王码零号ling 王码年份year 王码日期date 王码月份mont 王码星期week 王码时刻time


2-1.htm

正确姿势
坐姿端正，腰背挺直，两脚平放在地上。肩部放松，大臂自然下垂，前臂与基本键成水平线。打字的效率跟座位高低很有关系。一般来说，专职打字工作都使用转椅，以调节座位高低。身体与键盘的距离保持20厘米左右，肘部与腰部距离为10厘米左右，以上衣中线（钮扣或拉链）对准键盘正中，视线集中于左侧的打字底稿。
坐姿是打字的基本功之一，打字时，除了手指悬放在基本键上外，身体的其他任何部位都不能搁放在键盘边框或桌子上。端正坐姿是为了保持良好工作状态，打字准确、速度高又不易疲劳。